summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/genimage.scm4
-rw-r--r--gnu/packages/patches/genimage-signedness.patch24
2 files changed, 27 insertions, 1 deletions
diff --git a/gnu/packages/genimage.scm b/gnu/packages/genimage.scm
index 2525c50b48..c9ed6258a0 100644
--- a/gnu/packages/genimage.scm
+++ b/gnu/packages/genimage.scm
@@ -50,7 +50,9 @@
(file-name (string-append name "-" version "-checkout"))
(sha256
(base32
- "15jmh17lvm3jw9c92bjarly7iwhmnfl322d91mprfv10ppb9ip54"))))
+ "15jmh17lvm3jw9c92bjarly7iwhmnfl322d91mprfv10ppb9ip54"))
+ ;; will be shipped with release 14
+ (patches (search-patches "genimage-signedness.patch"))))
(build-system gnu-build-system)
(arguments
`(#:phases
diff --git a/gnu/packages/patches/genimage-signedness.patch b/gnu/packages/patches/genimage-signedness.patch
new file mode 100644
index 0000000000..2204dfb545
--- /dev/null
+++ b/gnu/packages/patches/genimage-signedness.patch
@@ -0,0 +1,24 @@
+commit 6574665f9d6c0757e8f55ccb465afbcaa90bf019
+Author: Timotej Lazar <timotej.lazar@araneo.si>
+Date: Wed Aug 19 19:36:02 2020 +0200
+
+ test: normalize flags reported by dumpe2fs
+
+ Filesystem flags depend on the system – usually signed_directory_hash,
+ but unsigned_directory_hash at least on arm64.
+
+ Signed-off-by: Timotej Lazar <timotej.lazar@araneo.si>
+
+diff --git a/test/basic-images.test b/test/basic-images.test
+index f6685e1..cb104c3 100755
+--- a/test/basic-images.test
++++ b/test/basic-images.test
+@@ -158,6 +158,8 @@ check_ext() {
+ # format change
+ csum2="Group 0: (Blocks 1-4095) \\[ITABLE_ZEROED\\]\| Checksum .*, unused inodes 205"
+ dumpe2fs "${1}" | grep -v "^\($uuid\|$seed\|$csum1\|$csum2\)" > "dump" &&
++ # some architectures (including arm64) use unsigned char
++ sed -i 's/un\(signed_directory_hash\)/\1/' "dump" &&
+ # fixup for ext3 journal size with old tune2fs
+ sed -i 's/^\(Journal size: \)1029k$/\11024k/' "dump" &&
+ # output format changed with some version