summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/patches/torsocks-dns-test.patch18
-rw-r--r--gnu/packages/tor.scm25
2 files changed, 6 insertions, 37 deletions
diff --git a/gnu/packages/patches/torsocks-dns-test.patch b/gnu/packages/patches/torsocks-dns-test.patch
deleted file mode 100644
index ba70ba5933..0000000000
--- a/gnu/packages/patches/torsocks-dns-test.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Skip DNS tests that rely on the ability to look up arbitary
-host names.
-
---- torsocks/tests/test_dns.c 2015-11-10 18:30:53.955941984 +0100
-+++ torsocks/tests/test_dns.c 2015-11-10 18:31:02.199941892 +0100
-@@ -134,11 +134,8 @@ static void test_getaddrinfo(const struc
- int main(int argc, char **argv)
- {
- /* Libtap call for the number of tests planned. */
-- plan_tests(NUM_TESTS);
-+ plan_tests(1);
-
-- test_getaddrinfo(&tor_check);
-- test_gethostbyname(&tor_dir_auth1);
-- test_gethostbyaddr(&tor_dir_auth2);
- test_getaddrinfo(&tor_localhost);
-
- return 0;
diff --git a/gnu/packages/tor.scm b/gnu/packages/tor.scm
index 0812b575ce..e6fbf6e005 100644
--- a/gnu/packages/tor.scm
+++ b/gnu/packages/tor.scm
@@ -30,7 +30,6 @@
#:use-module (gnu packages libevent)
#:use-module (gnu packages compression)
#:use-module (gnu packages pcre)
- #:use-module (gnu packages perl)
#:use-module (gnu packages python)
#:use-module (gnu packages qt)
#:use-module (gnu packages autotools)
@@ -73,28 +72,16 @@ applications based on the TCP protocol.")
(define-public torsocks
(package
(name "torsocks")
- (version "2.0.0")
+ (version "2.2.0")
(source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.torproject.org/torsocks.git")
- (commit (string-append "v" version))))
+ (method url-fetch)
+ (uri (string-append "https://people.torproject.org/~dgoulet/"
+ name "/" name "-" version ".tar.xz"))
(sha256
(base32
- "0an2q5ail9z414riyjbkjkm29504hy778j914baz2gn5hlv2cfak"))
- (file-name (string-append name "-" version "-checkout"))
- (patches (search-patches "torsocks-dns-test.patch"))))
+ "0byr9ga9w79qz4vp0m11sbmspad7fsal9wm67r4znzb7zb7cis19"))))
(build-system gnu-build-system)
- (arguments
- '(#:phases (modify-phases %standard-phases
- (add-before 'configure 'bootstrap
- (lambda _
- (system* "autoreconf" "-vfi"))))))
- (native-inputs `(("autoconf" ,(autoconf-wrapper))
- ("automake" ,automake)
- ("libtool" ,libtool)
- ("perl-test-harness" ,perl-test-harness)))
- (home-page "http://www.torproject.org/")
+ (home-page "https://www.torproject.org/")
(synopsis "Use socks-friendly applications with Tor")
(description
"Torsocks allows you to use most socks-friendly applications in a safe