summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/base.scm6
-rw-r--r--gnu/packages/gtk.scm4
-rw-r--r--gnu/packages/patches/libdrm-symbol-check.patch25
-rw-r--r--gnu/packages/pulseaudio.scm37
-rw-r--r--gnu/packages/video.scm4
-rw-r--r--gnu/packages/xdisorg.scm4
-rw-r--r--gnu/packages/xorg.scm25
7 files changed, 32 insertions, 73 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 5c36b612f1..072f401fc3 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -1001,7 +1001,7 @@ command.")
(define-public tzdata
(package
(name "tzdata")
- (version "2017a")
+ (version "2017b")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1009,7 +1009,7 @@ command.")
version ".tar.gz"))
(sha256
(base32
- "1mmv4rvcs12lrvgghw4fidczvb69yv69cmzknghcvw1c196mqfnz"))))
+ "11l0s43vx33dcs78p80122i8s5s9l1sjwkzzwh66njd35r92l97q"))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f
@@ -1057,7 +1057,7 @@ command.")
version ".tar.gz"))
(sha256
(base32
- "1b1q7gnlsh5hjgs5065pvajd37rmbc3k9b8cgzad1vcrifswdwh2"))))))
+ "0h1d567gn8l3iqgyadcswwdy2yh07nhz3lfl8ds8saz2ajxka5sd"))))))
(home-page "https://www.iana.org/time-zones")
(synopsis "Database of current and historical time zones")
(description "The Time Zone Database (often called tz or zoneinfo)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 770a8c9160..93970b0392 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -691,9 +691,9 @@ application suites.")
("python-wrapper" ,python-wrapper)
;; By using a special xorg-server for GTK+'s tests, we reduce the impact
;; of updating xorg-server directly on the master branch.
- ("xorg-server" ,xorg-server-1.19.2)))
+ ("xorg-server" ,xorg-server-1.19.3)))
(arguments
- `(#:disallowed-references (,xorg-server-1.19.2)
+ `(#:disallowed-references (,xorg-server-1.19.3)
;; 47 MiB goes to "out" (24 of which is locale data!), and 26 MiB goes
;; to "doc".
#:configure-flags (list (string-append "--with-html-dir="
diff --git a/gnu/packages/patches/libdrm-symbol-check.patch b/gnu/packages/patches/libdrm-symbol-check.patch
index 69c67e778d..0a77763a4f 100644
--- a/gnu/packages/patches/libdrm-symbol-check.patch
+++ b/gnu/packages/patches/libdrm-symbol-check.patch
@@ -174,26 +174,21 @@ mips64el-linux, armhf-linux and aarch64-linux.
@@ -1,6 +1,6 @@
#!/bin/bash
--# The following symbols (past the first five) are taken from the public headers.
-+# The following symbols (past the first 12) are taken from the public headers.
- # A list of the latter should be available Makefile.sources/LIBDRM_FREEDRENO_H_FILES
+-# The following symbols (past the first nine) are taken from tegra.h.
++# The following symbols (past the first 12) are taken from tegra.h.
FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_tegra.so} | awk '{print $3}'| while read func; do
-@@ -10,6 +10,13 @@
- _end
- _fini
- _init
+ ( grep -q "^$func$" || echo $func ) <<EOF
+@@ -9,6 +9,9 @@
+ __bss_start
+ __end__
+ _bss_end__
+_fbss
+_fdata
+_ftext
-+__bss_start__
-+__bss_end__
-+_bss_end__
-+__end__
- drm_tegra_bo_get_flags
- drm_tegra_bo_get_handle
- drm_tegra_bo_get_tiling
-
+ _edata
+ _end
+ _fini
--- libdrm-2.4.65/radeon/radeon-symbol-check.orig 2015-05-04 11:47:43.000000000 -0400
+++ libdrm-2.4.65/radeon/radeon-symbol-check 2015-10-18 23:57:00.756759698 -0400
@@ -1,6 +1,6 @@
diff --git a/gnu/packages/pulseaudio.scm b/gnu/packages/pulseaudio.scm
index 71fcc3f827..42fb5df5ae 100644
--- a/gnu/packages/pulseaudio.scm
+++ b/gnu/packages/pulseaudio.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;;
;;; This file is part of GNU Guix.
@@ -43,15 +44,14 @@
(define-public libsndfile
(package
(name "libsndfile")
- (replacement libsndfile-1.0.28)
- (version "1.0.27")
+ (version "1.0.28")
(source (origin
(method url-fetch)
(uri (string-append "http://www.mega-nerd.com/libsndfile/files/libsndfile-"
version ".tar.gz"))
(sha256
(base32
- "1h7s61nhf7vklh9sdsbbqzb6x287q4x4j1jc5gmjragl4wprb4d3"))))
+ "1afzm7jx34jhqn32clc5xghyjglccam2728yxlx37yj2y0lkkwqz"))))
(build-system gnu-build-system)
(inputs
`(("libvorbis" ,libvorbis)
@@ -74,31 +74,17 @@ SPARC. Hopefully the design of the library will also make it easy to extend
for reading and writing new sound file formats.")
(license l:gpl2+)))
-(define libsndfile-1.0.28
- (package
- (inherit libsndfile)
- (version "1.0.28")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "http://www.mega-nerd.com/libsndfile/files/libsndfile-"
- version ".tar.gz"))
- (sha256
- (base32
- "1afzm7jx34jhqn32clc5xghyjglccam2728yxlx37yj2y0lkkwqz"))))))
-
(define-public libsamplerate
(package
(name "libsamplerate") ; aka. Secret Rabbit Code (SRC)
- (replacement libsamplerate-0.1.9)
- (version "0.1.8")
+ (version "0.1.9")
(source (origin
(method url-fetch)
(uri (string-append "http://www.mega-nerd.com/SRC/libsamplerate-"
version ".tar.gz"))
(sha256
(base32
- "01hw5xjbjavh412y63brcslj5hi9wdgkjd3h9csx5rnm8vglpdck"))))
+ "1ha46i0nbibq0pl0pjwcqiyny4hj8lp1bnl4dpxm64zjw9lb2zha"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -126,19 +112,6 @@ the theoretical best bandwidth for a given pair of input and output sample
rates.")
(license l:gpl2+)))
-(define libsamplerate-0.1.9
- (package
- (inherit libsamplerate)
- (version "0.1.9")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "http://www.mega-nerd.com/SRC/libsamplerate-"
- version ".tar.gz"))
- (sha256
- (base32
- "1ha46i0nbibq0pl0pjwcqiyny4hj8lp1bnl4dpxm64zjw9lb2zha"))))))
-
(define-public pulseaudio
(package
(name "pulseaudio")
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 6599a326e4..f6dab288e3 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -404,7 +404,7 @@ SMPTE 314M.")
(define-public libva
(package
(name "libva")
- (version "1.7.3")
+ (version "1.8.1")
(source
(origin
(method url-fetch)
@@ -412,7 +412,7 @@ SMPTE 314M.")
"https://www.freedesktop.org/software/vaapi/releases/libva/libva-"
version".tar.bz2"))
(sha256
- (base32 "1ndrf136rlw03xag7j1xpmf9015d1h0dpnv6v587jnh6k2a17g12"))))
+ (base32 "0wswfznj93jpnxhc3jwdk5j3pmyki0rs6k9vk4vnzds0dddximf1"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 0467d5b357..89830a628a 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -277,7 +277,7 @@ rasterisation.")
(define-public libdrm
(package
(name "libdrm")
- (version "2.4.75")
+ (version "2.4.79")
(source
(origin
(method url-fetch)
@@ -287,7 +287,7 @@ rasterisation.")
".tar.bz2"))
(sha256
(base32
- "0kq5hmck0gq7b29fr8jp94njc7jpkpbyws12s63w4b21xw750nid"))
+ "15xiwnicf7vl1l37k8nj0z496p7ln1qp8qws7q13ikiv54cz7an6"))
(patches (search-patches "libdrm-symbol-check.patch"))))
(build-system gnu-build-system)
(inputs
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 635c1832a4..972ad73682 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -1095,7 +1095,7 @@ themselves.")
(define-public libpciaccess
(package
(name "libpciaccess")
- (version "0.13.4")
+ (version "0.13.5")
(source
(origin
(method url-fetch)
@@ -1105,7 +1105,7 @@ themselves.")
".tar.bz2"))
(sha256
(base32
- "1krgryi9ngjr66242v0v5mczihgv0y7rrvx0563arr318mjn9y07"))))
+ "16dr80rdw5bzdyhahvilfjrflj7scs2yl2mmghsb84f3nglm8b3m"))))
(build-system gnu-build-system)
(inputs
`(("zlib" ,zlib)))
@@ -4985,7 +4985,7 @@ over Xlib, including:
(define-public xorg-server
(package
(name "xorg-server")
- (version "1.19.2")
+ (version "1.19.3")
(source
(origin
(method url-fetch)
@@ -4994,7 +4994,7 @@ over Xlib, including:
name "-" version ".tar.bz2"))
(sha256
(base32
- "1fw4b2lf75nsqkiyhn95b1c2if1l3cw5a188a1szx1d8l7sbk2jg"))))
+ "162s1v901djr57gxmmk4airk8hiwcz79dqyz72972x1lw1k82yk7"))))
(build-system gnu-build-system)
(propagated-inputs
`(("dri2proto" ,dri2proto)
@@ -5053,12 +5053,7 @@ over Xlib, including:
("xcb-util-wm" ,xcb-util-wm)))
(native-inputs
`(("python" ,python-minimal-wrapper)
- ("pkg-config" ,pkg-config)
- ;; XXX Bootstrapping inputs for 1.19.2. Remove for > 1.19.2.
- ("font-util" ,font-util)
- ("libtool" ,libtool)
- ("autoconf" ,autoconf)
- ("automake" ,automake)))
+ ("pkg-config" ,pkg-config)))
(arguments
`(#:parallel-tests? #f
#:configure-flags
@@ -5085,10 +5080,6 @@ over Xlib, including:
#:phases
(modify-phases %standard-phases
- ;; XXX The 1.19.2 release of xorg-server was not bootstrapped:
- ;; <https://lists.x.org/archives/xorg-announce/2017-March/002780.html>
- (add-before 'configure 'bootstrap
- (lambda _ (zero? (system* "autoreconf" "-vfi"))))
(add-before
'configure 'pre-configure
(lambda _
@@ -5115,11 +5106,11 @@ draggable titlebars and borders.")
(license license:x11)))
;;; This package is intended to be used when building GTK+.
-(define-public xorg-server-1.19.2
+(define-public xorg-server-1.19.3
(package
(inherit xorg-server)
(name "xorg-server")
- (version "1.19.2")
+ (version "1.19.3")
(source
(origin
(method url-fetch)
@@ -5128,7 +5119,7 @@ draggable titlebars and borders.")
name "-" version ".tar.bz2"))
(sha256
(base32
- "1fw4b2lf75nsqkiyhn95b1c2if1l3cw5a188a1szx1d8l7sbk2jg"))))))
+ "162s1v901djr57gxmmk4airk8hiwcz79dqyz72972x1lw1k82yk7"))))))
(define-public xorg-server-xwayland
(package