summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/icu4c.scm3
-rw-r--r--gnu/packages/patches/icu4c-test-date-format.patch17
2 files changed, 19 insertions, 1 deletions
diff --git a/gnu/packages/icu4c.scm b/gnu/packages/icu4c.scm
index 45dcfe2466..de1bc1be2c 100644
--- a/gnu/packages/icu4c.scm
+++ b/gnu/packages/icu4c.scm
@@ -37,7 +37,8 @@
(string-map (lambda (x) (if (char=? x #\.) #\_ x)) version)
"-src.tgz"))
(sha256 (base32
- "14l0kl17nirc34frcybzg0snknaks23abhdxkmsqg3k9sil5wk9g"))))
+ "14l0kl17nirc34frcybzg0snknaks23abhdxkmsqg3k9sil5wk9g")))
+ (patches (list (search-patch "icu4c-test-date-format.patch"))))
(build-system gnu-build-system)
(inputs
`(("patchelf" ,patchelf)
diff --git a/gnu/packages/patches/icu4c-test-date-format.patch b/gnu/packages/patches/icu4c-test-date-format.patch
new file mode 100644
index 0000000000..d7f0df98a6
--- /dev/null
+++ b/gnu/packages/patches/icu4c-test-date-format.patch
@@ -0,0 +1,17 @@
+Starting with the switch to GCC 4.8.3, we observed this test failure.
+Changing "34" to "134" means that we expect the date to be parsed as
+"2034", not "1934", which seems consistent with the line above.
+
+Reported at <http://bugs.icu-project.org/trac/ticket/10960>.
+
+--- icu/source/test/intltest/dtfmttst.cpp 2014-06-16 10:35:46.000000000 +0200
++++ icu/source/test/intltest/dtfmttst.cpp 2014-06-16 10:35:52.000000000 +0200
+@@ -1129,7 +1129,7 @@ DateFormatTest::TestTwoDigitYear()
+ return;
+ }
+ parse2DigitYear(fmt, "5/6/17", date(117, UCAL_JUNE, 5));
+- parse2DigitYear(fmt, "4/6/34", date(34, UCAL_JUNE, 4));
++ parse2DigitYear(fmt, "4/6/34", date(134, UCAL_JUNE, 4));
+ }
+
+ // -------------------------------------