summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/libreoffice.scm1
-rw-r--r--gnu/packages/patches/libwpd-gcc-compat.patch17
2 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index b17a144f7c..77527b909a 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -236,6 +236,7 @@ spreadsheets and presentations.")
(method url-fetch)
(uri (string-append "mirror://sourceforge/libwpd/libwpd/"
"libwpd-" version "/libwpd-" version ".tar.xz"))
+ (patches (search-patches "libwpd-gcc-compat.patch"))
(sha256 (base32
"02fx8bngslcj7i5g1gx2kiign4vp09wrmp5wpvix9igxcavb0r94"))))
(build-system gnu-build-system)
diff --git a/gnu/packages/patches/libwpd-gcc-compat.patch b/gnu/packages/patches/libwpd-gcc-compat.patch
new file mode 100644
index 0000000000..ee206beafe
--- /dev/null
+++ b/gnu/packages/patches/libwpd-gcc-compat.patch
@@ -0,0 +1,17 @@
+Fix build with newer GCC.
+
+Taken from upstream:
+
+ https://sourceforge.net/p/libwpd/code/ci/333c8a26f231bea26ec3d56245315041bbf5577f/
+
+--- a/src/lib/WPXTable.h
++++ b/src/lib/WPXTable.h
+@@ -53,7 +53,7 @@
+ ~WPXTable();
+ void insertRow();
+ void insertCell(unsigned char colSpan, unsigned char rowSpan, unsigned char borderBits);
+- const WPXTableCell *getCell(size_t i, size_t j)
++ const WPXTableCell *getCell(std::size_t i, std::size_t j)
+ {
+ return &(m_tableRows[i])[j];
+ }