summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/documentation.scm4
-rw-r--r--gnu/packages/patches/doxygen-support-gcc-12.patch15
2 files changed, 18 insertions, 1 deletions
diff --git a/gnu/packages/documentation.scm b/gnu/packages/documentation.scm
index ab54041320..180b556cbf 100644
--- a/gnu/packages/documentation.scm
+++ b/gnu/packages/documentation.scm
@@ -198,7 +198,9 @@ markup) can be customized and extended by the user.")
".src.tar.gz")))
(sha256
(base32
- "0dqzgci82z950pzg6cpxvvqwybi2031flml3pj47hayhq3c9qpm1"))))
+ "0dqzgci82z950pzg6cpxvvqwybi2031flml3pj47hayhq3c9qpm1"))
+ ;; Remove with next release.
+ (patches (search-patches "doxygen-support-gcc-12.patch"))))
(build-system cmake-build-system)
(native-inputs
(list bison
diff --git a/gnu/packages/patches/doxygen-support-gcc-12.patch b/gnu/packages/patches/doxygen-support-gcc-12.patch
new file mode 100644
index 0000000000..01f5040dde
--- /dev/null
+++ b/gnu/packages/patches/doxygen-support-gcc-12.patch
@@ -0,0 +1,15 @@
+Fix for https://github.com/doxygen/doxygen/issues/9312 made in unreleased upstream commit
+https://github.com/doxygen/doxygen/commit/5198966c8d5fec89116d025c74934ac03ea511fa
+
+diff --git a/src/cache.h b/src/cache.h
+index 0ff3092ed5..e218eb27d2 100644
+--- a/src/cache.h
++++ b/src/cache.h
+@@ -19,6 +19,7 @@
+ #include <list>
+ #include <unordered_map>
+ #include <mutex>
++#include <utility>
+ #include <ctype.h>
+
+ /*! Fixed size cache for value type V using keys of type K.