summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b68af1efb7..ba81580258 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -2505,6 +2505,40 @@ does not use formula input or special syntax, but can be used in combination
with default R plot functions.")
(license license:gpl2+)))
+(define-public r-plumber
+ (package
+ (name "r-plumber")
+ (version "1.2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "plumber" version))
+ (sha256
+ (base32
+ "1k0y7ylc8bld16imn86g0i0dmxmr3kmh9ax4ys0yrxqzrvji7z3g"))))
+ (properties `((upstream-name . "plumber")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-crayon
+ r-ellipsis
+ r-httpuv
+ r-jsonlite
+ r-lifecycle
+ r-magrittr
+ r-mime
+ r-promises
+ r-r6
+ r-rlang
+ r-sodium
+ r-stringi
+ r-swagger
+ r-webutils))
+ (home-page "https://www.rplumber.io")
+ (synopsis "API generator for R")
+ (description
+ "This package gives you the ability to automatically generate and serve
+an HTTP API from R functions using the annotations in the R documentation
+around your functions.")
+ (license license:expat)))
+
(define-public r-polychrome
(package
(name "r-polychrome")