summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/php.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/php.scm b/gnu/packages/php.scm
index 8d96e54c90..ffb81da5fc 100644
--- a/gnu/packages/php.scm
+++ b/gnu/packages/php.scm
@@ -86,7 +86,7 @@
#t))))
(build-system gnu-build-system)
(arguments
- '(#:configure-flags
+ `(#:configure-flags
(let-syntax ((with (syntax-rules ()
((_ option input)
(string-append option "="
@@ -182,6 +182,17 @@
(substitute* "ext/standard/tests/streams/bug60602.phpt"
(("'ls'") (string-append "'" (which "ls") "'")))
+ ,@(if (string-prefix? "armhf" (or (%current-system)
+ (%current-target-system)))
+ ;; Drop tests known to fail on armhf.
+ '((for-each delete-file
+ (list
+ "ext/calendar/tests/unixtojd_error1.phpt"
+ ;; arm can be a lot slower, so a time-related test fails
+ "ext/fileinfo/tests/cve-2014-3538-nojit.phpt"
+ "ext/pcre/tests/bug76514.phpt"
+ "ext/pcre/tests/preg_match_error3.phpt"))))
+
;; Drop tests that are known to fail.
(for-each delete-file
'("ext/posix/tests/posix_getgrgid.phpt" ; Requires /etc/group.