summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/version-control.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 9a27b8f1e9..1dd3eaaa82 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -846,6 +846,12 @@ to GitHub contributions calendar.")
'()))
#:phases
(modify-phases %standard-phases
+ ,@(if (target-arm32?)
+ ;; Some tests are flaky on armhf.
+ '((add-before 'check 'pre-check
+ (lambda _
+ (setenv "GITTEST_FLAKY_STAT" "true"))))
+ '())
;; Run checks more verbosely, unless we are cross-compiling.
(replace 'check
(lambda* (#:key (tests? #t) #:allow-other-keys)