summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gtk.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 385e4e97e4..f6a50f0058 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -24,6 +24,7 @@
;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2020 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2020 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -649,6 +650,24 @@ is part of the GNOME accessibility project.")
(license license:lgpl2.0+)
(home-page "https://projects.gnome.org/accessibility/")))
+;;; A minimal variant used to prevent a cycle with Inkscape.
+(define at-spi2-core-minimal
+ (package
+ (inherit at-spi2-core)
+ (name "at-spi2-core-minimal")
+ (outputs (delete "doc" (package-outputs at-spi2-core)))
+ (arguments
+ (substitute-keyword-arguments (package-arguments at-spi2-core)
+ ((#:configure-flags configure-flags)
+ `(delete "-Ddocs=true" ,configure-flags))
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (delete 'set-documentation-path)
+ (delete 'prepare-doc-directory)
+ (delete 'move-documentation)))))
+ (native-inputs
+ (alist-delete "gtk-doc" (package-native-inputs at-spi2-core)))))
+
(define-public at-spi2-atk
(package
(name "at-spi2-atk")