summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 90dd1b7d4d..cf86c71970 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -8799,11 +8799,9 @@ library.")
(base32
"17zajiw4mjbkkv6ahp3xf025qglkj0805m9s41c45zryzj6p2h39"))))
(build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda _ (zero? (system* "python" "./test_pathlib.py")))))))
+ ;; The tests depend on the internal "test" module, which does not provide
+ ;; a stable interface.
+ (arguments `(#:tests? #f))
(home-page "https://pathlib.readthedocs.org/")
(synopsis "Object-oriented file system paths")
(description "Pathlib offers a set of classes to handle file system paths.