summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index cae6a36858..ab052badbd 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -17757,6 +17757,28 @@ experience by providing optional integration with other popular Emacs packages
like @code{company}, @code{flycheck}, and @code{projectile}.")
(license license:gpl3+)))
+(define-public emacs-pfuture
+ (let ((commit "368254ee30692c709400db413c347e18e76a8a55"))
+ (package
+ (name "emacs-pfuture")
+ (version (git-version "1.6" "1" commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Alexander-Miller/pfuture.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "096raqpjx84njws85r7pqq1wi9w9bjwkr0ga1mbbhlna1mfn3mg4"))))
+ (build-system emacs-build-system)
+ (home-page
+ "https://github.com/Alexander-Miller/pfuture")
+ (synopsis "Simple wrapper around asynchronous processes for Emacs")
+ (description "This package provides a simple wrapper around asynchronous
+processes for Emacs")
+ (license license:gpl3+))))
+
(define-public emacs-lsp-ui
(package
(name "emacs-lsp-ui")