summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm2
-rw-r--r--gnu/packages/web.scm24
2 files changed, 25 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 26d827b82e..211333314f 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8290,7 +8290,7 @@ functionality and behavior.")
("inkscape" ,inkscape)
("optipng" ,optipng)
("pkg-config" ,pkg-config)
- ("sassc" ,sassc)))
+ ("sassc" ,sassc/libsass-3.5)))
(synopsis "A flat GTK+ theme with transparent elements")
(description "Arc is a flat theme with transparent elements for GTK 3, GTK
2, and GNOME Shell which supports GTK 3 and GTK 2 based desktop environments
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index b2d282710a..032ba2206c 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1516,6 +1516,7 @@ minimum to provide high performance operation.")
(define-public libsass
(package
(name "libsass")
+ ;; When updating, check whether sassc/libsass-3.5 is still needed.
(version "3.6.3")
(source (origin
(method git-fetch)
@@ -1595,6 +1596,29 @@ language known as SASS.")
(home-page "https://sass-lang.com/libsass")
(license license:expat)))
+(define-public sassc/libsass-3.5
+ ;; Newer libsass versions suffor from a memory leak when building (some?)
+ ;; GTK themes <https://github.com/sass/libsass/issues/3033>.
+ (package
+ (inherit sassc)
+ (name "sassc")
+ (inputs
+ `(("libsass" ,
+ (package
+ (inherit libsass)
+ (name "libsass")
+ (version "3.5.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sass/libsass.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0830pjcvhzxh6yixj82x5k5r1xnadjqzi16kp53213icbly0r9ma"))))))))))
+
(define-public perl-apache-logformat-compiler
(package