summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index d401e5c456..c0f8ff0204 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -533,8 +533,13 @@ statistical profiler, a code coverage tool, and many other extensions.")
(install-file kernel libdir)
(install-file heap libdir)
- (let ((dirs '("lib" "library" "examples" "contrib"
- "tools" "objc-bridge")))
+ (let ((dirs '("lib" "library" "examples" "tools" "objc-bridge"
+ ,@(match (%current-system)
+ ("x86_64-linux"
+ '("x86-headers64"))
+ ("i686-linux"
+ '("x86-headers"))
+ (_ '())))))
(for-each copy-recursively
dirs
(map (cut string-append libdir <>) dirs)))
@@ -551,7 +556,7 @@ statistical profiler, a code coverage tool, and many other extensions.")
(chmod wrapper #o755))
#t)))))
(supported-systems '("i686-linux" "x86_64-linux" "armhf-linux"))
- (home-page "http://ccl.clozure.com/")
+ (home-page "https://ccl.clozure.com/")
(synopsis "Common Lisp implementation")
(description "Clozure CL (often called CCL for short) is a Common Lisp
implementation featuring fast compilation speed, native threads, a precise,