summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 7b46aad340..2f1652f8db 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -8072,4 +8072,24 @@ only those tests that failed in the last run, or to only run the tests that have
been added since previous test run.")
(license license:bsd-3)))
+(define-public ghc-ieee754
+ (package
+ (name "ghc-ieee754")
+ (version "0.7.8")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/ieee754/"
+ "ieee754-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1zvfnnd5nm5kgr60214cdyks0kqdqyzpwk5sdh0s60yr8b7fyjny"))))
+ (build-system haskell-build-system)
+ (home-page "http://github.com/patperry/hs-ieee754")
+ (synopsis "Utilities for dealing with IEEE floating point numbers")
+ (description "Utilities for dealing with IEEE floating point numbers,
+ported from the Tango math library; approximate and exact equality comparisons
+for general types.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here