summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 5296c43c53..fd1d6dd4c7 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -248,7 +248,12 @@ for efficient socket-like bidirectional reliable communication channels.")
(sha256
(base32
"10s7xxxx6pp4ydp3san69sa6q379ih3pv92fyi565ggmlw8igv7a"))
- (file-name (string-append name "-" version ".tar.gz"))))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; Believe it or not, the .pc is invalid. Fix it.
+ '(substitute* "libpsl.pc.in"
+ (("-llibpsl") "-lpsl")))))
(build-system gnu-build-system)
(inputs `(("icu4c" ,icu4c)))
;; The release tarball lacks the generated files.