summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/statistics.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 333b1b6894..06872fdaec 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -4209,3 +4209,27 @@ original public code has been corrected.")
models. The functionality is experimental and the user interface is likely
to change in the future.")
(license license:gpl2)))
+
+(define-public r-flexmix
+ (package
+ (name "r-flexmix")
+ (version "2.3-13")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "flexmix" version))
+ (sha256
+ (base32
+ "1i205yw3kkxs27gqcs6zx0c2mh16p332a2p06wq6fdzb20bazg3z"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-modeltools" ,r-modeltools)))
+ (home-page "http://cran.r-project.org/web/packages/flexmix")
+ (synopsis "Flexible mixture modeling")
+ (description
+ "This package implements a general framework for finite mixtures of
+regression models using the EM algorithm. FlexMix provides the E-step and
+all data handling, while the M-step can be supplied by the user to easily
+define new models. Existing drivers implement mixtures of standard linear
+models, generalized linear models and model-based clustering.")
+ (license license:gpl2+)))