summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm32
-rw-r--r--gnu/packages/golang.scm31
2 files changed, 32 insertions, 31 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 5911461a59..0b3db6e379 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -821,6 +821,38 @@ expressing configuration which is easy for both humans and machines to read.")
(home-page "https://github.com/hashicorp/hcl")
(license license:mpl2.0)))
+(define-public go-github-com-hashicorp-hcl-v2
+ (package
+ (name "go-github-com-hashicorp-hcl-v2")
+ (version "2.11.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hashicorp/hcl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0f9flmmkj7fr1337fc56cqy73faq87ix375hnz3id4wc023przv1"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/hashicorp/hcl/v2"))
+ (native-inputs
+ (list go-github-com-davecgh-go-spew))
+ (inputs
+ (list go-github-com-agext-levenshtein
+ go-github-com-apparentlymart-go-textseg-v13
+ go-github-com-mitchellh-go-wordwrap
+ go-github-com-zclconf-go-cty))
+ (synopsis "Go implementation of HashiCorp Configuration Language V2")
+ (description
+ "This package contains the main implementation of the @acronym{HCL,
+HashiCorp Configuration Language}. HCL is designed to be a language for
+expressing configuration which is easy for both humans and machines to read.")
+ (home-page "https://github.com/hashicorp/hcl")
+ (license license:mpl2.0)))
+
(define-public go-github-com-hashicorp-go-multierror
(package
(name "go-github-com-hashicorp-go-multierror")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 3fa3ed7ebf..d12902290e 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3304,37 +3304,6 @@ command-line parsers.")
(home-page "https://github.com/tj/docopt")
(license license:expat)))
-(define-public go-github-com-hashicorp-hcl-v2
- (package
- (name "go-github-com-hashicorp-hcl-v2")
- (version "2.11.1")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/hashicorp/hcl")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0f9flmmkj7fr1337fc56cqy73faq87ix375hnz3id4wc023przv1"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/hashicorp/hcl/v2"))
- (native-inputs
- (list go-github-com-davecgh-go-spew))
- (inputs
- (list go-github-com-agext-levenshtein go-github-com-mitchellh-go-wordwrap
- go-github-com-zclconf-go-cty
- go-github-com-apparentlymart-go-textseg-v13))
- (synopsis "Go implementation of HashiCorp Configuration Language V2")
- (description
- "This package contains the main implementation of the @acronym{HCL,
-HashiCorp Configuration Language}. HCL is designed to be a language for
-expressing configuration which is easy for both humans and machines to read.")
- (home-page "https://github.com/hashicorp/hcl")
- (license license:mpl2.0)))
-
(define-public govulncheck
(package
(name "govulncheck")