summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 5c6a7b812e..1c85faea17 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3628,6 +3628,14 @@ for dealing with different structured file formats.")
("rust-yeslogic-fontconfig-sys" ,rust-yeslogic-fontconfig-sys-2))
#:phases
#~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-gdk-pixbuf-thumbnailer
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; The gdk-pixbuf-thumbnailer location is assumed to be relative
+ ;; to librsvg's own installation prefix (see:
+ ;; https://gitlab.gnome.org/GNOME/librsvg/-/issues/955).
+ (substitute* "gdk-pixbuf-loader/librsvg.thumbnailer.in"
+ (("@bindir@/gdk-pixbuf-thumbnailer")
+ (search-input-file inputs "bin/gdk-pixbuf-thumbnailer")))))
(add-after 'unpack 'prepare-for-build
(lambda _
;; In lieu of #:make-flags