summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 46232d3c98..ca5d67b2e6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -32058,7 +32058,15 @@ and frame grabber interface.")
;; nondeterministically (see:
;; https://github.com/scikit-build/scikit-build/issues/711).
"and not test_generator_cleanup "
- "and not test_generator_selection "))))))))
+ "and not test_generator_selection ")))))
+ (add-after 'install 'install-cmake
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((lib (string-append (assoc-ref outputs "out")
+ "/lib/cmake/modules")))
+ (mkdir-p lib)
+ (with-directory-excursion "skbuild/resources/cmake"
+ (for-each (lambda (file) (install-file file lib))
+ (find-files "." "\\.cmake")))))))))
(native-inputs
(list cmake-minimal
gfortran