summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 07c25e2443..4c64bbe1db 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -220,7 +220,8 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
(extra-version #f)
(configuration-file #f)
(defconfig "defconfig")
- (extra-options %default-extra-linux-options))
+ (extra-options %default-extra-linux-options)
+ (patches (list %boot-logo-patch)))
(package
(name (if extra-version
(string-append "linux-libre-" extra-version)
@@ -230,7 +231,7 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
(method url-fetch)
(uri (linux-libre-urls version))
(sha256 (base32 hash))
- (patches (list %boot-logo-patch))))
+ (patches patches)))
(supported-systems supported-systems)
(build-system gnu-build-system)
(native-inputs