summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 9b43f465cc..2971dfe779 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -200,6 +200,14 @@
(guix build utils) (guix build gnu-build-system))
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'remove-findleaks-from-testopts
+ (lambda _
+ (substitute* "Makefile.pre.in"
+ ;; -l which is short for --findleaks isn't compatible with the
+ ;; -j flag added through the #:make-flags, therefore remove
+ ;; it. This only affects python-2.7.
+ (("TESTOPTS= -l ") "TESTOPTS= "))
+ #t))
(add-before
'configure 'patch-lib-shells
(lambda _