summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-web.scm24
-rw-r--r--gnu/packages/golang.scm24
2 files changed, 24 insertions, 24 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 6a832291ab..751eb41b58 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -314,6 +314,30 @@ selection based on their relative weighting. This package is useful for
network applications that require accessing services using SRV records.")
(license license:asl2.0)))
+(define-public go-github-com-jcmturner-goidentity-v6
+ (package
+ (name "go-github-com-jcmturner-goidentity-v6")
+ (version "6.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jcmturner/goidentity")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "064ysvxvrvij843s7qj1nkzl5qc6j1qbrsb3s0zmwd1sa7vq8q1n"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/jcmturner/goidentity/v6"))
+ (propagated-inputs
+ (list go-github-com-stretchr-testify go-github-com-hashicorp-go-uuid))
+ (home-page "https://github.com/jcmturner/goidentity")
+ (synopsis "Hold authenticated identities and their attributes")
+ (description "This package provides a standard interface for holding
+authenticated identities and their attributes.")
+ (license license:asl2.0)))
+
(define-public go-github-com-jcmturner-gokrb5-v8
(package
(name "go-github-com-jcmturner-gokrb5-v8")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 44eb9122b9..6cccf2098a 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1499,30 +1499,6 @@ not included in the Go standard library.")
encryption and decryption methods.")
(license license:asl2.0)))
-(define-public go-github-com-jcmturner-goidentity-v6
- (package
- (name "go-github-com-jcmturner-goidentity-v6")
- (version "6.0.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/jcmturner/goidentity")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "064ysvxvrvij843s7qj1nkzl5qc6j1qbrsb3s0zmwd1sa7vq8q1n"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/jcmturner/goidentity/v6"))
- (propagated-inputs
- (list go-github-com-stretchr-testify go-github-com-hashicorp-go-uuid))
- (home-page "https://github.com/jcmturner/goidentity")
- (synopsis "Hold authenticated identities and their attributes")
- (description "This package provides a standard interface for holding
-authenticated identities and their attributes.")
- (license license:asl2.0)))
-
(define-public go-github-com-jcmturner-gofork
(package
(name "go-github-com-jcmturner-gofork")