summaryrefslogtreecommitdiff
path: root/guix/config.scm.in.in
diff options
context:
space:
mode:
Diffstat (limited to 'guix/config.scm.in.in')
-rw-r--r--guix/config.scm.in.in120
1 files changed, 120 insertions, 0 deletions
diff --git a/guix/config.scm.in.in b/guix/config.scm.in.in
new file mode 100644
index 0000000000..1f1e41924a
--- /dev/null
+++ b/guix/config.scm.in.in
@@ -0,0 +1,120 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2017 Caleb Ristvedt <caleb.ristvedt@cune.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (guix config)
+ #:export (%guix-package-name
+ %guix-version
+ %guix-bug-report-address
+ %guix-home-page-url
+
+ %storedir
+ %localstatedir
+ %sysconfdir
+ %temp-directory
+ %libexecdir
+
+ %store-directory
+ %state-directory
+ %store-database-directory
+ %config-directory
+
+ %system
+ %libz
+ %liblz
+ %gzip
+ %bzip2
+ %xz
+ %impersonate-linux-2.6?))
+
+;;; Commentary:
+;;;
+;;; Compile-time configuration of Guix. When adding a substitution variable
+;;; here, make sure to equip (guix scripts pull) to substitute it.
+;;;
+;;; Code:
+
+(define %guix-package-name
+ "@PACKAGE_NAME@")
+
+(define %guix-version
+ "@PACKAGE_VERSION@")
+
+(define %guix-bug-report-address
+ "@PACKAGE_BUGREPORT@")
+
+(define %guix-home-page-url
+ "@PACKAGE_URL@")
+
+(define %storedir
+ "@storedir@")
+
+(define %localstatedir
+ "@guix_localstatedir@")
+
+(define %temp-directory
+ (or (getenv "TMPDIR")
+ "/tmp"))
+
+(define %impersonate-linux-2.6?
+ (make-parameter @impersonate_linux26@))
+
+(define %sysconfdir
+ "@guix_sysconfdir@")
+
+(define %libexecdir
+ (or (getenv "NIX_LIBEXEC_DIR")
+ "@Libexecdir@/guix"))
+
+(define %store-directory
+ (or (and=> (getenv "NIX_STORE_DIR") canonicalize-path)
+ %storedir))
+
+(define %state-directory
+ ;; This must match `NIX_STATE_DIR' as defined in `nix/local.mk'.
+ (or (getenv "GUIX_STATE_DIRECTORY")
+ (string-append %localstatedir "/guix")))
+
+(define %store-database-directory
+ (or (getenv "GUIX_DATABASE_DIRECTORY")
+ (string-append %state-directory "/db")))
+
+(define %config-directory
+ ;; This must match `GUIX_CONFIGURATION_DIRECTORY' as defined in `nix/local.mk'.
+ (or (getenv "GUIX_CONFIGURATION_DIRECTORY")
+ (string-append %sysconfdir "/guix")))
+
+(define %system
+ "@guix_system@")
+
+(define %libz
+ "@LIBZ@")
+
+(define %liblz
+ "@LIBLZ@")
+
+(define %gzip
+ "@GZIP@")
+
+(define %bzip2
+ "@BZIP2@")
+
+(define %xz
+ "@XZ@")
+
+;;; config.scm ends here