summaryrefslogtreecommitdiff
path: root/po/doc/local.mk
diff options
context:
space:
mode:
Diffstat (limited to 'po/doc/local.mk')
-rw-r--r--po/doc/local.mk10
1 files changed, 8 insertions, 2 deletions
diff --git a/po/doc/local.mk b/po/doc/local.mk
index 77ec4721e3..419898a139 100644
--- a/po/doc/local.mk
+++ b/po/doc/local.mk
@@ -2,6 +2,7 @@
# Copyright © 2018 Julien Lepiller <julien@lepiller.eu>
# Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
# Copyright © 2024 Janneke Nieuwenhuizen <janneke@gnu.org>
+# Copyright © 2024 gemmaro <gemmaro.dev@gmail.com>
#
# This file is part of GNU Guix.
#
@@ -45,8 +46,13 @@ POT_OPTIONS = \
--msgid-bugs-address "bug-guix@gnu.org"
%D%/%.pot: $(srcdir)/doc/%.texi
- $(AM_V_PO4A)$(PO4A_UPDATEPO) -M UTF-8 -f texinfo -m "$<" \
- -p "$@-t" $(POT_OPTIONS)
+ $(AM_V_PO4A)$(PO4A) --no-translations -M UTF-8 \
+ --package-version "$(VERSION)" \
+ --variable master="$<" \
+ --variable pot="$@-t" \
+ --variable po=/dev/null \
+ --variable localized=/dev/null \
+ $(POT_OPTIONS) %D%/po4a.cfg
date="$$(git log --pretty=format:%ci -n 1 -- $< 2>/dev/null \
|| echo $(SOURCE_DATE_EPOCH))" \
sed -ri -e "s,^(.POT-Creation-Date: )[^\]*,\1$$date," "$@-t"