summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2023-04-10 21:22:22 -0400
committerJohn Kehayias <john.kehayias@protonmail.com>2023-04-25 11:23:14 -0400
commitc6b747700f028084e2d3e5d25cd962277fd6ea65 (patch)
treecd4d86d27b5a4b31f88814af22b4981bbffdd6ad
parenta562bcfbac111021929ac70147963bb1c38a083f (diff)
nongnu: steam-client-libs: Rename fontconfig-fixed to fontconfig.core-updates
* nongnu/packages/steam-client.scm (steam-client-libs): Rename fontconfig-fixed to fontconfig. The upstream bug has not been fixed but expat has been ungrafted in core-updates so we no longer need to rewrite fontconfig. Remove fontconfig-fixed as expat/fixed no longer exists in core-updates.
-rw-r--r--nongnu/packages/steam-client.scm17
1 files changed, 1 insertions, 16 deletions
diff --git a/nongnu/packages/steam-client.scm b/nongnu/packages/steam-client.scm
index 08baba8..885a65f 100644
--- a/nongnu/packages/steam-client.scm
+++ b/nongnu/packages/steam-client.scm
@@ -170,20 +170,6 @@
(patches (delete (car (search-patches "glibc-dl-cache.patch"))
(origin-patches (package-source glibc))))))))
-;; After guix commit to add a replacement for expat (security fixes),
-;; https://git.savannah.gnu.org/cgit/guix.git/commit/?id=2045852b096131a714409aa0cc4fe17938f60b15
-;; a profile collision happens with the propagated expat (now grafted) from
-;; fontconfig. See upstream report https://issues.guix.gnu.org/53406
-;; So we define a fontconfig variation that explicitly does the expat replacement
-;; which works around this bug for now, at the cost of building fontconfig.
-;; TODO: remove once upstream bug is fixed
-(define fontconfig-fixed
- (package
- (inherit fontconfig)
- (propagated-inputs
- (modify-inputs (package-propagated-inputs fontconfig)
- (replace "expat" (@@ (gnu packages xml) expat/fixed))))))
-
(define fhs-min-libs
`(("glibc" ,glibc-for-fhs)
("glibc-locales" ,glibc-locales)))
@@ -195,8 +181,7 @@
("dbus-glib" ,dbus-glib) ; Required for steam browser.
("elfutils" ,elfutils) ; Required for capturing library dependencies in pv.
("eudev" ,eudev) ; Required for steamwebhelper/heavy runtime.
- ;; TODO: set back to ,fontconfig once https://issues.guix.gnu.org/53406 is fixed
- ("fontconfig" ,fontconfig-fixed) ; Required for steam client.
+ ("fontconfig" ,fontconfig) ; Required for steam client.
("file" ,file) ; Used for steam installation.
("find" ,findutils) ; Required at least for some logging.
("freetype" ,freetype) ; Required for steam login.