summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Brielmaier <jonathan.brielmaier@web.de>2022-08-23 18:38:23 +0200
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2022-08-23 18:38:23 +0200
commit13644a6bb8ccfd0e76c1f59874493f231d033292 (patch)
tree8f276d0d4c6ac174baed9a99ad89043d3d08d810
parentf1961c103a5cdf6f4c520e4002bbbaf46b7ab6e8 (diff)
nongnu: firefox-esr: Update to 102.2.0esr [security fixes].
This fixes CVE-2022-38472, CVE-2022-38473, CVE-2022-38476, CVE-2022-38477 and CVE-2022-38478. * nongnu/packages/mozilla.scm (firefox-esr): Update to 102.2.0esr.
-rw-r--r--nongnu/packages/mozilla.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/nongnu/packages/mozilla.scm b/nongnu/packages/mozilla.scm
index b1da29f..53abc52 100644
--- a/nongnu/packages/mozilla.scm
+++ b/nongnu/packages/mozilla.scm
@@ -533,19 +533,19 @@ according to Unicode Standard Annex #31")
;; Update this id with every firefox update to it's release date.
;; It's used for cache validation and therefor can lead to strange bugs.
-(define %firefox-esr-build-id "20220726000000")
+(define %firefox-esr-build-id "20220823000000")
(define-public firefox-esr
(package
(name "firefox-esr")
- (version "102.1.0esr")
+ (version "102.2.0esr")
(source
(origin
(method url-fetch)
(uri (string-append "https://archive.mozilla.org/pub/firefox/releases/"
version "/source/firefox-" version ".source.tar.xz"))
(sha256
- (base32 "0q4lawxynvdiihlqnqiwxdp0ai71qq2fp6mkdsy5p08vgmr6wyv3"))))
+ (base32 "1zwpgis7py1bf8p88pz3mpai6a02qrdb8ww2fa9kxxdl9b8r2k81"))))
(build-system gnu-build-system)
(arguments
(list