summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2022-12-03 23:09:20 +0100
committerJelle Licht <jlicht@fsfe.org>2022-12-03 23:09:20 +0100
commite5cc8b2c7bdc3e3673434b880c4de338b34b492b (patch)
tree213f53291456fdb58dec2d79ab7a9a325bd5aabc
parent5117915f0a6e01cf98894f42dc831f3ddeacb283 (diff)
nongnu: firefox-esr: Fix VA-API support, again.firefox-sandbox-for-vaapi
This also fixes the firefox package. Supersedes dfc2b256eb.
-rw-r--r--nongnu/packages/mozilla.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/nongnu/packages/mozilla.scm b/nongnu/packages/mozilla.scm
index 09f050e..8d43b2e 100644
--- a/nongnu/packages/mozilla.scm
+++ b/nongnu/packages/mozilla.scm
@@ -334,6 +334,11 @@ according to Unicode Standard Annex #31")
;; XDG settings should be managed by Guix.
(write-setting "browser.shell.checkDefaultBrowser" "false")
(close-port port))))
+ (add-after 'fix-preferences 'fix-store-permissions
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Piggyback off of (and overwrite) the existing NixOS sandbox policy
+ (substitute* "security/sandbox/linux/broker/SandboxBrokerPolicyFactory.cpp"
+ (("/nix/store") "/gnu/store"))))
(add-after 'fix-preferences 'fix-ffmpeg-runtime-linker
(lambda* (#:key inputs #:allow-other-keys)
(let* ((ffmpeg (assoc-ref inputs "ffmpeg"))