summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2023-01-03 14:33:50 -0500
committerJohn Kehayias <john.kehayias@protonmail.com>2023-01-03 14:33:50 -0500
commit18678da1d7ff8b58cd4c882d25d3280f0897067a (patch)
tree87870d8a558d3ecb112a8508549988ded2704879
parent23a84f72d59209c1905eeed39c2148cbb792fd56 (diff)
nongnu: steam: Fix URL handling.
This replaces 'xdg-utils' with 'flatpak-xdg-utils' so that the steam container will call out to the host to open URLs and properly handle steam:// URLs as well. This requires portals on the host, e.g. xdg-desktop-portal-gtk. * nongnu/packages/steam-client.scm (steam-client-libs): Replace 'xdg-utils' with 'flatpak-xdg-utils'.
-rw-r--r--nongnu/packages/steam-client.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/nongnu/packages/steam-client.scm b/nongnu/packages/steam-client.scm
index dca7eef..08baba8 100644
--- a/nongnu/packages/steam-client.scm
+++ b/nongnu/packages/steam-client.scm
@@ -219,7 +219,7 @@
("usbutils" ,usbutils) ; Required for SteamVR.
("util-linux" ,util-linux) ; Required for steam login.
("wayland" ,wayland) ; Required for mesa vulkan (e.g. libvulkan_radeon).
- ("xdg-utils" ,xdg-utils)
+ ("flatpak-xdg-utils" ,flatpak-xdg-utils)
("xz" ,xz)
("zenity" ,zenity))) ; Required for progress dialogs.