summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZhu Zihao <all_but_last@163.com>2023-01-27 18:08:16 +0800
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2023-02-02 11:28:05 +0100
commit1ffeebab4743263053d15c473395379d51f7b0b0 (patch)
tree9385170ad8cbd66d38e46df9b073f02cfc4dadac
parent65e37da0d1641436fffb34b36b609095643310f2 (diff)
nongnu: rtl8821ce-linux-module: Remove duplicated definition.
* nongnu/packages/linux.scm (rtl8821ce-linux-module): Remove duplicated definition. Signed-off-by: Jonathan Brielmaier <jonathan.brielmaier@web.de>
-rw-r--r--nongnu/packages/linux.scm41
1 files changed, 0 insertions, 41 deletions
diff --git a/nongnu/packages/linux.scm b/nongnu/packages/linux.scm
index 9f7b788..011818f 100644
--- a/nongnu/packages/linux.scm
+++ b/nongnu/packages/linux.scm
@@ -951,44 +951,3 @@ audio DSPs that can be found on the Intel Skylake architecture. This
firmware can be built from source but need to be signed by Intel in order to be
loaded by Linux.")
(license bsd-3)))
-
-(define-public rtl8821ce-linux-module
- (let ((commit "50c1b120b06a3b0805e23ca9a4dbd274d74bb305")
- (revision "8"))
- (package
- (name "rtl8821ce-linux-module")
- (version (git-version "0.0.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/tomaspinho/rtl8821ce")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "09dsmbsrpnbpbq4kigq324s8xb567pdjyb5h07kg6xcbcb5npkpz"))))
- (build-system linux-module-build-system)
- (arguments
- (list #:make-flags
- #~(list (string-append "CC=" #$(cc-for-target))
- (string-append "KSRC="
- (assoc-ref %build-inputs
- "linux-module-builder")
- "/lib/modules/build"))
- #:phases
- #~(modify-phases %standard-phases
- (replace 'build
- (lambda* (#:key (make-flags '()) (parallel-build? #t)
- #:allow-other-keys)
- (apply invoke "make"
- `(,@(if parallel-build?
- `("-j" ,(number->string (parallel-job-count)))
- '())
- ,@make-flags)))))
- #:tests? #f)) ; no test suite
- (home-page "https://github.com/tomaspinho/rtl8821ce")
- (synopsis "Linux driver for Realtek RTL8821CE wireless network adapters")
- (description "This is Realtek's RTL8821CE Linux driver for wireless
-network adapters.")
- (license gpl2))))