summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2023-01-11 00:43:46 +0100
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2023-01-11 00:43:46 +0100
commit5c0ac46c708c648cc2c8cc35c83cef8b4ed343fe (patch)
tree8ff3cacf7edfda70a6593d2a476f37ddce92fa6d
parent4ce94dd8c7b967046bc9b702a9b3a955825a03be (diff)
nongnu: Add anx7688-firmware.
* nongnu/packages/firmware.scm (anx7688-firmware): New variable.
-rw-r--r--nongnu/packages/firmware.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/nongnu/packages/firmware.scm b/nongnu/packages/firmware.scm
index dfd2913..de8554c 100644
--- a/nongnu/packages/firmware.scm
+++ b/nongnu/packages/firmware.scm
@@ -80,3 +80,27 @@ in the PinePhone.")
WiFi/Bluetooth chip in the PinePhone.")
(home-page "https://megous.com/git/linux-firmware")
(license (nonfree (string-append "unknown"))))))
+
+(define-public anx7688-firmware
+ (let ((commit "6e8e591e17e207644dfe747e51026967bb1edab5")
+ (revision "1"))
+ (package
+ (name "anx7688-firmware")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://megous.com/git/linux-firmware")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "19xmkdvlkczc6zgigy8jdbgnp37i6pc03m2cm3gilvzg8m7v18ad"))))
+ (build-system copy-build-system)
+ (arguments
+ `(#:install-plan '(("anx7688-fw.bin" "lib/firmware/"))))
+ (synopsis "Firmware for the ANX7688")
+ (description "This package provides binary firmware for the ANX7688
+HDMI to USB Type-C Bridge in the PinePhone.")
+ (home-page "https://megous.com/git/linux-firmware")
+ (license (nonfree (string-append "unknown"))))))