summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2023-01-11 00:59:26 +0100
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2023-01-11 00:59:26 +0100
commit7ca71bae0a6e3655d984867a65ca06422cb1b3f6 (patch)
tree978232619431b7b3c374b7144028933230d7eb98
parentf3317615488de1067cb5f6c0bdf71833c63b1ba8 (diff)
nongnu: Add bluez-firmware.
* nongnu/packages/firmware.scm (bluez-firmware): New variable. Signed-off-by: Jonathan Brielmaier <jonathan.brielmaier@web.de>
-rw-r--r--nongnu/packages/firmware.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/nongnu/packages/firmware.scm b/nongnu/packages/firmware.scm
index ff97ea4..43b2928 100644
--- a/nongnu/packages/firmware.scm
+++ b/nongnu/packages/firmware.scm
@@ -6,8 +6,11 @@
#:use-module (gnu packages efi)
#:use-module (gnu packages firmware)
#:use-module (guix build-system copy)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix download)
#:use-module (guix gexp)
#:use-module (guix git-download)
+ #:use-module ((guix licenses) #:prefix guix-license:)
#:use-module (guix packages)
#:use-module (guix utils)
#:use-module (nonguix licenses))
@@ -139,3 +142,33 @@ HDMI to USB Type-C Bridge in the PinePhone.")
found in Pinebook Pro.")
(home-page "https://gitlab.manjaro.org/manjaro-arm/packages/community/ap6256-firmware")
(license (nonfree (string-append "unknown"))))))
+
+(define-public bluez-firmware
+ (package
+ (name "bluez-firmware")
+ (version "1.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://bluez.sf.net/download/" name "-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1v4yv6gvlvvwslpb0lj1nsp4r900zxpvxz2ab0sbvimbiw8rw4dn"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ (add-after 'install-license-files 'relocate-copyright
+ (lambda* _
+ (install-file (string-append #$output
+ "/lib/firmware/BCM-LEGAL.txt")
+ (string-append #$output
+ "/share/doc/bluez-firmware-"
+ #$(package-version bluez-firmware)
+ "/BCM-LEGAL.txt")))))))
+ (synopsis "Firmware for Broadcom BCM203x and STLC2300 Bluetooth chips")
+ (description "This package provides firmware for Broadcom BCM203x
+and STLC2300 Bluetooth chips.")
+ (home-page "https://github.com/RPi-Distro/bluez-firmware")
+ (license (list guix-license:gpl2+
+ (nonfree
+ "file:///share/doc/bluez-firmware-1.2/BCM-LEGAL.txt")))))