summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2023-01-17 23:19:06 -0500
committerJohn Kehayias <john.kehayias@protonmail.com>2023-01-17 23:19:06 -0500
commit94f631012a56772cbd154e30f8844d6039d6277f (patch)
treec53696b37adac1a7348b08d7e7c9e56361cdeea4
parentce3a334e1c4e09805486ebee0410e9c5d352cd4d (diff)
nongnu: firefox-esr: Update to 102.7.0 [security fixes].
Fixes CVE-2022-46871, CVE-2022-46877, CVE-2023-23598, CVE-2023-23599, CVE-2023-23601, CVE-2023-23602, CVE-2023-23603, and CVE-2023-23605. * nongnu/packages/mozilla.scm (firefox-esr): Update to 102.7.0.
-rw-r--r--nongnu/packages/mozilla.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/nongnu/packages/mozilla.scm b/nongnu/packages/mozilla.scm
index 85040f0..d685851 100644
--- a/nongnu/packages/mozilla.scm
+++ b/nongnu/packages/mozilla.scm
@@ -233,19 +233,19 @@ according to Unicode Standard Annex #31")
;; Update this id with every firefox update to it's release date.
;; It's used for cache validation and therefor can lead to strange bugs.
-(define %firefox-esr-build-id "20221213000000")
+(define %firefox-esr-build-id "20230117000000")
(define-public firefox-esr
(package
(name "firefox-esr")
- (version "102.6.0esr")
+ (version "102.7.0esr")
(source
(origin
(method url-fetch)
(uri (string-append "https://archive.mozilla.org/pub/firefox/releases/"
version "/source/firefox-" version ".source.tar.xz"))
(sha256
- (base32 "1zhggzrk7lgip8jm37idh22qks76kmjy4yqy2qi63mvnv2j58cfj"))))
+ (base32 "1ahl66x8chnsz80capqa5ivyrqhc50s91zrcgz1jxd7w2ws61957"))))
(build-system gnu-build-system)
(arguments
(list