summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2023-01-17 23:15:50 -0500
committerJohn Kehayias <john.kehayias@protonmail.com>2023-01-17 23:15:50 -0500
commitce3a334e1c4e09805486ebee0410e9c5d352cd4d (patch)
tree25ac8f0bdb9df7f2e97901c7c4ace06b3a93f16c
parentc52224b54d80c72cf08508750180b7cf833cd244 (diff)
nongnu: firefox: Update to 109.0 [security fixes].
Fixes CVE-2023-23597, CVE-2023-23598, CVE-2023-23599, CVE-2023-23600, CVE-2023-23601, CVE-2023-23602, CVE-2023-23603, CVE-2023-23604, CVE-2023-23605, and CVE-2023-23606. * nongnu/packages/mozilla.scm (firefox): Update to 109.0.
-rw-r--r--nongnu/packages/mozilla.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/nongnu/packages/mozilla.scm b/nongnu/packages/mozilla.scm
index 9ab8bad..85040f0 100644
--- a/nongnu/packages/mozilla.scm
+++ b/nongnu/packages/mozilla.scm
@@ -18,7 +18,7 @@
;;; Copyright © 2020 Zhu Zihao <all_but_last@163.com>
;;; Copyright © 2021 pineapples <guixuser6392@protonmail.com>
;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
-;;; Copyright © 2021, 2022 John Kehayias <john.kehayias@protonmail.com>
+;;; Copyright © 2021, 2022, 2023 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2022 Pierre Langlois <pierre.langlois@gmx.com>
(define-module (nongnu packages mozilla)
@@ -650,20 +650,20 @@ MOZ_ENABLE_WAYLAND=1 exec ~a $@\n"
;; Update this id with every firefox update to it's release date.
;; It's used for cache validation and therefor can lead to strange bugs.
-(define %firefox-build-id "20230105000000")
+(define %firefox-build-id "20230117000000")
(define-public firefox
(package
(inherit firefox-esr)
(name "firefox")
- (version "108.0.2")
+ (version "109.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://archive.mozilla.org/pub/firefox/releases/"
version "/source/firefox-" version ".source.tar.xz"))
(sha256
- (base32 "00539ij5v0448l9nxsfcvfr9xj9nmn46hwyxr57llsfhgarddrj2"))))
+ (base32 "0lcklrv619b3kda8xh52bqggib1nn8jkm4phhpxr4n9bawxs0y06"))))
(arguments
(substitute-keyword-arguments (package-arguments firefox-esr)
((#:phases phases)