summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Brielmaier <jonathan.brielmaier@web.de>2022-12-14 11:44:12 +0100
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2022-12-14 11:44:12 +0100
commitd77b0d270ddb3952b80957e15f977b32326a5690 (patch)
tree0b9fdd317aeb9c00eb4293df38a8bf627b48b729
parent3d53be2c5cc9e0a8f5a76447eb392d7b0901232d (diff)
nongnu: firefox-esr: Update to 102.6.0esr [security fixes].
Fixes CVE-2022-46872, CVE-2022-46874, CVE-2022-46875, CVE-2022-46878, CVE-2022-46880, CVE-2022-46881 and CVE-2022-46882. * nongnu/packages/mozilla.scm (firefox-esr): Update to 102.6.0esr.
-rw-r--r--nongnu/packages/mozilla.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/nongnu/packages/mozilla.scm b/nongnu/packages/mozilla.scm
index 09f050e..5de742b 100644
--- a/nongnu/packages/mozilla.scm
+++ b/nongnu/packages/mozilla.scm
@@ -248,19 +248,19 @@ according to Unicode Standard Annex #31")
;; Update this id with every firefox update to it's release date.
;; It's used for cache validation and therefor can lead to strange bugs.
-(define %firefox-esr-build-id "20221115000000")
+(define %firefox-esr-build-id "20221213000000")
(define-public firefox-esr
(package
(name "firefox-esr")
- (version "102.5.0esr")
+ (version "102.6.0esr")
(source
(origin
(method url-fetch)
(uri (string-append "https://archive.mozilla.org/pub/firefox/releases/"
version "/source/firefox-" version ".source.tar.xz"))
(sha256
- (base32 "1n2pq165fxmvgcr5mv3hhaid2vn7lh3jg03lf13kz4c5295x8z81"))))
+ (base32 "1zhggzrk7lgip8jm37idh22qks76kmjy4yqy2qi63mvnv2j58cfj"))))
(build-system gnu-build-system)
(arguments
(list