summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Kandur <rndd@tuta.io>2023-05-29 14:31:46 +0300
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2023-06-18 12:24:06 +0200
commit47568e4fb27cfb78e662df986f0562cfd721c45f (patch)
tree261b39055932393a3e9e26971546e9c32e256ab8
parentd06e36978df54c3aebfabef59a765eb17b01a11b (diff)
nongnu: corrupt-linux: Pass defconfig value.
* nongnu/packages/linux.scm (corrupt-linux): Pass defconfig value. Signed-off-by: Jonathan Brielmaier <jonathan.brielmaier@web.de>
-rw-r--r--nongnu/packages/linux.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/nongnu/packages/linux.scm b/nongnu/packages/linux.scm
index 22c977d..7a68c7a 100644
--- a/nongnu/packages/linux.scm
+++ b/nongnu/packages/linux.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2023 Krzysztof Baranowski <pharcosyle@gmail.com>
;;; Copyright © 2023 Morgan Smith <Morgan.J.Smith@outlook.com>
;;; Copyright © 2023 Jelle Licht <jlicht@fsfe.org>
+;;; Copyright © 2023 Adam Kandur <rndd@tuta.io>
(define-module (nongnu packages linux)
#:use-module (gnu packages)
@@ -48,7 +49,11 @@
"/linux/kernel/v" (version-major version) ".x"
"/linux-" version ".tar.xz"))
-(define* (corrupt-linux freedo #:key (name "linux") (configs '()))
+(define* (corrupt-linux freedo
+ #:key
+ (name "linux")
+ (configs '())
+ (defconfig #f))
;; TODO: This very directly depends on guix internals.
;; Throw it all out when we manage kernel hashes.
@@ -80,7 +85,8 @@
(method url-fetch)
(uri url)
(hash hash))
- #:configs configs))
+ #:configs configs
+ #:defconfig defconfig))
(version version)
(home-page "https://www.kernel.org/")
(synopsis "Linux kernel with nonfree binary blobs included")