summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2023-05-19 22:01:37 +0200
committerJohn Kehayias <john.kehayias@protonmail.com>2023-09-07 17:07:23 -0400
commit5155d7ec303dde4f75e0ca1a66e926225e450255 (patch)
tree768a9420dc64e261d4dbe4336fa115a123bd58d5
parentb06a2a40ef2314de7110ac5c7e04fbdadc1e1d19 (diff)
nongnu: Add kompose.
* nongnu/packages/k8s.scm (kompose): New variable. Signed-off-by: John Kehayias <john.kehayias@protonmail.com>
-rw-r--r--nongnu/packages/k8s.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/nongnu/packages/k8s.scm b/nongnu/packages/k8s.scm
index bf20352..7f42f5d 100644
--- a/nongnu/packages/k8s.scm
+++ b/nongnu/packages/k8s.scm
@@ -110,3 +110,37 @@ Helm Chart for Kubernetes.")
use kubectl to deploy applications, inspect and manage cluster resources, and
view logs.")
(license license:asl2.0)))
+
+(define-public kompose
+ (package
+ (name "kompose")
+ (version "1.30.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/kubernetes/kompose/releases/download/v"
+ version "/kompose-linux-amd64"))
+ (sha256
+ (base32
+ "0sy3ci7s2dkjigasyv01nm1vg30wwhmdc0cmglzb23ws8bfrfjlh"))))
+ (build-system copy-build-system)
+ (arguments
+ (list
+ #:substitutable? #f
+ #:install-plan
+ #~'(("kompose" "bin/"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'unpack
+ (lambda _
+ (copy-file #$source "./kompose")))
+ (add-before 'install 'chmod
+ (lambda _
+ (chmod "kompose" #o555))))))
+ (home-page "https://kompose.io")
+ (supported-systems '("x86_64-linux"))
+ (synopsis "Go from Docker Compose to Kubernetes")
+ (description
+ "Kompose is a conversion tool for Docker Compose to container orchestrators
+such as Kubernetes (or OpenShift).")
+ (license license:expat)))