summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2023-05-19 21:43:58 +0200
committerJohn Kehayias <john.kehayias@protonmail.com>2023-09-07 17:06:55 -0400
commit5e48b63976d66e950bffd8c9bd7e11364ee442bd (patch)
tree4518d2f7b6f97c865a9f005f7ca694e6dcf59aa1
parent8ba0c3409605eaa6427234a2610b7802dad57396 (diff)
nongnu: Add katenary.
* nongnu/packages/k8s.scm (katenary): New variable. Signed-off-by: John Kehayias <john.kehayias@protonmail.com>
-rw-r--r--nongnu/packages/k8s.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/nongnu/packages/k8s.scm b/nongnu/packages/k8s.scm
index 3389b3f..b380aee 100644
--- a/nongnu/packages/k8s.scm
+++ b/nongnu/packages/k8s.scm
@@ -40,3 +40,38 @@ aim of this project is to make it easier to navigate, observe and manage your
applications in the wild. K9s continually watches Kubernetes for changes and
offers subsequent commands to interact with your observed resources.")
(license license:asl2.0)))
+
+(define-public katenary
+ (package
+ (name "katenary")
+ (version "2.0.0-beta2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/metal3d/katenary/releases/download/"
+ version "/katenary-linux-amd64"))
+ (sha256
+ (base32
+ "0vk5c82bf5aasrgz2b7qdjlbmlcjha0r3swmrbs9y5mms18y7m3i"))))
+ (build-system copy-build-system)
+ (arguments
+ (list
+ #:substitutable? #f
+ #:install-plan
+ #~'(("katenary" "bin/"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'unpack
+ (lambda _
+ (copy-file #$source "./katenary")
+ (chmod "katenary" #o644)))
+ (add-before 'install 'chmod
+ (lambda _
+ (chmod "katenary" #o555))))))
+ (home-page "https://github.com/metal3d/katenary")
+ (supported-systems '("x86_64-linux"))
+ (synopsis "Convert docker-compose to a configurable helm chart")
+ (description
+ "Katenary is a tool to help to transform docker-compose files to a working
+Helm Chart for Kubernetes.")
+ (license license:expat)))