summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2023-07-30 16:06:43 +0200
committerJelle Licht <jlicht@fsfe.org>2023-07-30 16:07:18 +0200
commit6b796ed3455911c5ee1a0ebb83ef77963b14c62d (patch)
tree43d9547e260e06b19d7c4069eae4a1517ae953ec
parent71730a861d70d2167a70bb156fa195c436f255c5 (diff)
nongnu: intel-media-driver: Use gexps.
* nongnu/packages/video.scm (intel-media-driver): Use gexp.
-rw-r--r--nongnu/packages/video.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/nongnu/packages/video.scm b/nongnu/packages/video.scm
index 2bbf61c..df745fc 100644
--- a/nongnu/packages/video.scm
+++ b/nongnu/packages/video.scm
@@ -6,6 +6,7 @@
#:use-module (gnu packages video)
#:use-module (guix build utils)
#:use-module (guix build-system cmake)
+ #:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (guix packages)
#:use-module ((guix licenses) #:prefix license:))
@@ -52,11 +53,11 @@ for VAAPI.")
(inputs (list libva gmmlib))
(native-inputs (list pkg-config))
(arguments
- '(#:tests? #f ;Tests are run as part of the normal build step
- #:configure-flags
- (list "-DENABLE_NONFREE_KERNELS=OFF"
- (string-append "-DLIBVA_DRIVERS_PATH="
- (assoc-ref %outputs "out") "/lib/dri"))))
+ (list #:tests? #f ;Tests are run as part of the normal build step
+ #:configure-flags
+ #~(list "-DENABLE_NONFREE_KERNELS=OFF"
+ (string-append "-DLIBVA_DRIVERS_PATH="
+ #$output "/lib/dri"))))
;; XXX Because of <https://issues.guix.gnu.org/issue/22138>, we need to add
;; this to all VA-API back ends instead of once to libva.
(native-search-paths