summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Brielmaier <jonathan.brielmaier@web.de>2022-12-10 19:08:47 +0100
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2022-12-10 19:08:47 +0100
commit53e294452b0aedf7837ab53932bedc6b7b5e16a0 (patch)
treed2e8000b0874dbb2273966465976a1cee6545c89
parent25ab067f0208a1e31b558411a1c2f32d2727ee21 (diff)
nongnu: Fix typo in variable name of font-microsoft-courier-new.
Fixes https://gitlab.com/nonguix/nonguix/-/issues/221 * nongnu/packages/fonts.scm (font-microsoft-couirer-new): Rename to font-microsoft-courier-new. Deprecate the wrong spelling.
-rw-r--r--nongnu/packages/fonts.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/nongnu/packages/fonts.scm b/nongnu/packages/fonts.scm
index 7120fef..3e5ede7 100644
--- a/nongnu/packages/fonts.scm
+++ b/nongnu/packages/fonts.scm
@@ -20,6 +20,7 @@
(define-module (nongnu packages fonts)
#:use-module (ice-9 string-fun)
#:use-module (gnu packages compression)
+ #:use-module (guix deprecation)
#:use-module (guix download)
#:use-module (guix packages)
#:use-module (guix build-system font)
@@ -90,13 +91,16 @@ font from the pack of Microsoft core fonts for the web."))
#:font-name "Comic Sans MS"
#:hash "0ki0rljjc1pxkbsxg515fwx15yc95bdyaksa3pjd89nyxzzg6vcw"))
-(define-public font-microsoft-couirer-new
+(define-public font-microsoft-courier-new
(mscorefont
"courie32"
#:version "2.82"
#:font-name "Courier New"
#:hash "111k3waxki9yyxpjwl2qrdkswvsd2dmvhbjmmrwyipam2s31sldv"))
+(define-public font-microsoft-couirer-new
+ (deprecated-package "font-microsoft-couirer-new" font-microsoft-courier-new))
+
(define-public font-microsoft-georgia
(mscorefont
"georgi32"