summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimotej Lazar <timotej.lazar@araneo.si>2020-10-02 14:46:43 +0200
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2020-10-02 16:22:09 +0200
commit2c46dfd5ecbd5d34dcc07bb94c606b95ac31cd66 (patch)
treebc311a45427b93aa74a96059e4159c18c03bde54
parent5d83bd2e981b1b0f0fc8ce49042d769ebb4bb1dc (diff)
gnu: eduke32: Update to 188e146.
* nongnu/packages/game-development.scm (eduke32): Update to 188e146. [inputs]: Add alsa-lib. Signed-off-by: Jonathan Brielmaier <jonathan.brielmaier@web.de>
-rw-r--r--nongnu/packages/game-development.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/nongnu/packages/game-development.scm b/nongnu/packages/game-development.scm
index 00ebb00..0974af5 100644
--- a/nongnu/packages/game-development.scm
+++ b/nongnu/packages/game-development.scm
@@ -30,6 +30,7 @@
#:use-module (gnu packages gcc)
#:use-module (gnu packages gl)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages linux)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages sdl)
#:use-module (gnu packages video)
@@ -175,8 +176,8 @@ development should opt for GLSL rather than Cg.")
(define-public eduke32
;; There are no official releases.
- (let ((commit "26f683cadb3ca731cb8f19ae011cd6431f276827")
- (revision "0")
+ (let ((commit "188e14622cfe5c6f63b04b989b350bf2a29a893c")
+ (revision "1")
(duke-nukem-3d-directory "share/dukenukem3d"))
(package
(name "eduke32")
@@ -189,7 +190,7 @@ development should opt for GLSL rather than Cg.")
(commit commit)))
(file-name (git-file-name name version))
(sha256
- (base32 "15y8p35wbb83k3yh4ydpibf64maqnmbqmw89dinlfhllcdm9154n"))
+ (base32 "0wy4bppiw4q2hn0v38msrjyvj2hzfvigakc23c2wqfnbl7rm0hrz"))
;; Unbundle libxmp.
(modules '((guix build utils)))
(snippet
@@ -255,6 +256,7 @@ exec -a \"$0\" ~a\
`(("pkg-config" ,pkg-config)))
(inputs
`(("sdl-union" ,(sdl-union (list sdl2 sdl2-mixer)))
+ ("alsa-lib" ,alsa-lib)
("glu" ,glu)
("libvorbis" ,libvorbis)
("libvpx" ,libvpx)