summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Brielmaier <jonathan.brielmaier@web.de>2023-03-14 19:23:29 +0100
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2023-03-14 19:23:29 +0100
commit07f6c3fb2b825fb1b14b2896f9e650fee6ae916a (patch)
tree2262987af40ccf45b640675d54e542a44a1c7dd4
parent2dde2a60067ee383b753b85d608a7c20ff315634 (diff)
nongnu: firefox-esr: Update to 102.9.0esr [security fixes].
Fixes CVE-2023-25751, CVE-2023-25752, CVE-2023-28162, CVE-2023-28163, CVE-2023-28164 and CVE-2023-28176. * nongnu/packages/mozilla.scm (firefox-esr): Update to 102.9.0esr.
-rw-r--r--nongnu/packages/mozilla.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/nongnu/packages/mozilla.scm b/nongnu/packages/mozilla.scm
index 4a18ed9..b9384d8 100644
--- a/nongnu/packages/mozilla.scm
+++ b/nongnu/packages/mozilla.scm
@@ -249,19 +249,19 @@ according to Unicode Standard Annex #31")
;; Update this id with every firefox update to it's release date.
;; It's used for cache validation and therefor can lead to strange bugs.
-(define %firefox-esr-build-id "20230214000000")
+(define %firefox-esr-build-id "20230313000000")
(define-public firefox-esr
(package
(name "firefox-esr")
- (version "102.8.0esr")
+ (version "102.9.0esr")
(source
(origin
(method url-fetch)
(uri (string-append "https://archive.mozilla.org/pub/firefox/releases/"
version "/source/firefox-" version ".source.tar.xz"))
(sha256
- (base32 "0j6afrgfsmd0adbbmffw4p1f2hznpck9d36z3bsjx36f7cjgdy27"))))
+ (base32 "1l8xlbba8sa9dg132k96ch8mz97i5lyhpvkxi8d85jh97xi79c1i"))))
(build-system gnu-build-system)
(arguments
(list