summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2022-12-02 17:51:53 -0500
committerJohn Kehayias <john.kehayias@protonmail.com>2023-04-22 21:25:37 -0400
commit1a3437446234b948961ccca8560cdaa905a982f2 (patch)
tree0af6d5b784fadd7802029d216aa16ec318d202d5
parent57bae7065199683fb6fd56bfe55171b33390a513 (diff)
nongnu: mesa: Update to 22.3.0.
* nongnu/packages/mesa.scm (mesa-next): Update to 22.3.0. [phases]{fix-instrfromstring-test}: Remove. Test has been fixed in upstream with this release.
-rw-r--r--nongnu/packages/mesa.scm13
1 files changed, 2 insertions, 11 deletions
diff --git a/nongnu/packages/mesa.scm b/nongnu/packages/mesa.scm
index cf662f2..2bab5aa 100644
--- a/nongnu/packages/mesa.scm
+++ b/nongnu/packages/mesa.scm
@@ -78,7 +78,7 @@
(define-public mesa-next
(package
(name "mesa")
- (version "22.2.2")
+ (version "22.3.0")
(source
(origin
(method url-fetch)
@@ -90,7 +90,7 @@
version "/mesa-" version ".tar.xz")))
(sha256
(base32
- "1ya8i7kz98h6vdyfjmlpnvcd237a7hhgwjcfh4dngk659yvizq9d"))))
+ "0ihp63756kmp9rd0w83li1lf98saigail4b2hywc4j25b0vgjjv4"))))
(build-system meson-build-system)
(propagated-inputs
;; The following are in the Requires.private field of gl.pc.
@@ -237,15 +237,6 @@ svga,swrast,virgl")))
(("'lp_test_arit', ") ""))))
(_
'((display "No tests to disable on this architecture.\n"))))))
- ,@(if (string=? (%current-system) "i686-linux")
- '((add-after 'disable-failing-test 'fix-instrfromstring-test
- (lambda _
- ;; The instrfromstring test fails on i686, which has been already
- ;; fixed upstream but not in 22.2.1.
- ;; TODO: remove on update
- (substitute* "src/gallium/drivers/r600/sfn/sfn_instr_export.cpp"
- (("buf\\[6\\]") "buf[6] = {0}")))))
- '())
(add-before 'configure 'fix-dlopen-libnames
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))