summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2022-10-14 20:40:08 -0400
committerJohn Kehayias <john.kehayias@protonmail.com>2022-11-04 20:43:47 -0400
commit2e180fa39373737c05d8b1163ec238a57aaee8c2 (patch)
tree11023aebc0ff4aea092edf9ed78730118808e4dd
parent182b6f18e6b52de6871efe5a1f336c05a497de7a (diff)
nongnu: mesa-next: Fix failing test for i686-linux.
* nongnu/packages/mesa.scm (mesa-next)[phases]{fix-instrfromstring-test}: New phase. Fix the instrfromstring test which fails on i686 using the upstream change.
-rw-r--r--nongnu/packages/mesa.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/nongnu/packages/mesa.scm b/nongnu/packages/mesa.scm
index 3f5053c..8272715 100644
--- a/nongnu/packages/mesa.scm
+++ b/nongnu/packages/mesa.scm
@@ -237,6 +237,15 @@ svga,swrast,virgl")))
(("'lp_test_arit', ") ""))))
(_
'((display "No tests to disable on this architecture.\n"))))))
+ ,@(if (string=? (%current-system) "i686-linux")
+ '((add-after 'disable-failing-test 'fix-instrfromstring-test
+ (lambda _
+ ;; The instrfromstring test fails on i686, which has been already
+ ;; fixed upstream but not in 22.2.1.
+ ;; TODO: remove on update
+ (substitute* "src/gallium/drivers/r600/sfn/sfn_instr_export.cpp"
+ (("buf\\[6\\]") "buf[6] = {0}")))))
+ '())
(add-before 'configure 'fix-dlopen-libnames
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))