summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Brielmaier <jonathan.brielmaier@web.de>2023-02-26 11:52:24 +0100
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2023-02-26 11:52:24 +0100
commit3a1e9f0507d99403d1ba0f5557ee868b95b61eef (patch)
tree74d2a23d756eea6d6df8ca5a7bedad8697426130
parent301eb285639a082aada6153c6eae58998916704f (diff)
nongnu: firefox: Update to 110.0 [security fixes].
Fixes CVE-2023-0767, CVE-2023-25728, CVE-2023-25729, CVE-2023-25730, CVE-2023-25731, CVE-2023-25732, CVE-2023-25733, CVE-2023-25734, CVE-2023-25736, CVE-2023-25737, CVE-2023-25738, CVE-2023-25739, CVE-2023-25740, CVE-2023-25741, CVE-2023-25742, CVE-2023-25744 and CVE-2023-25745. * nongnu/packages/mozilla.scm (firefox): Update to 110.0. [inputs]: Use icu4c-72. (rust-firefox): Update to rust-1.65.
-rw-r--r--nongnu/packages/mozilla.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/nongnu/packages/mozilla.scm b/nongnu/packages/mozilla.scm
index 84852fe..a330a67 100644
--- a/nongnu/packages/mozilla.scm
+++ b/nongnu/packages/mozilla.scm
@@ -75,7 +75,7 @@
;; https://searchfox.org under the particular firefox release, like
;; mozilla-esr102.
(define-public rust-firefox-esr rust) ; 1.60 is the default in Guix
-(define-public rust-firefox (@@ (gnu packages rust) rust-1.63)) ; 1.63 is also listed, but 1.61 is the minimum needed
+(define-public rust-firefox (@@ (gnu packages rust) rust-1.65)) ; 1.63 is also listed, but 1.61 is the minimum needed
;; rust-cbindgen-0.23/0.24 dependencies
(define-public rust-unicode-ident-1
@@ -666,20 +666,20 @@ MOZ_ENABLE_WAYLAND=1 exec ~a $@\n"
;; Update this id with every firefox update to it's release date.
;; It's used for cache validation and therefor can lead to strange bugs.
-(define %firefox-build-id "20230131000000")
+(define %firefox-build-id "20230214000000")
(define-public firefox
(package
(inherit firefox-esr)
(name "firefox")
- (version "109.0.1")
+ (version "110.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://archive.mozilla.org/pub/firefox/releases/"
version "/source/firefox-" version ".source.tar.xz"))
(sha256
- (base32 "1n9isyq5i55j35n471qv1j56zz53fwryz4dwwxx3mvi377xzshsy"))))
+ (base32 "0fca2vckwr2x65xka90x07xyy0slvqswywi72kxdqkqf3692926k"))))
(arguments
(substitute-keyword-arguments (package-arguments firefox-esr)
((#:phases phases)
@@ -687,6 +687,9 @@ MOZ_ENABLE_WAYLAND=1 exec ~a $@\n"
(replace 'set-build-id
(lambda _
(setenv "MOZ_BUILD_DATE" #$%firefox-build-id)))))))
+ (inputs
+ (modify-inputs (package-inputs firefox-esr)
+ (replace "icu4c" icu4c-72)))
(native-inputs
(modify-inputs (package-native-inputs firefox-esr)
(replace "rust" rust-firefox)