summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2023-03-17 15:11:38 -0400
committerJohn Kehayias <john.kehayias@protonmail.com>2023-03-17 15:21:59 -0400
commit76d776a3f547081e8f98036f7d685b99e3a84762 (patch)
tree91be7855880ed96eefaa8211e8b4de757d0b7285
parent075c001aac558d364ecff0033f7edbd6898a7d91 (diff)
nongnu: zoom: Fix failure to run.
Fixes #252. Zoom launches again. * nongnu/packages/messaging.scm: Remove unused (gnu packages qt). (zoom)[inputs]: Add mit-krb5, xcb-util, xcb-util-renderutil, xcb-util-wm and remove qtmultimedia. [phases]{wrap-where-patchelf-does-not-work}: Add mit-krb5, libxcb, libxext, xcb-util, xcb-util-wm, and xcb-util-renderutil to LD_LIBRARY_PATH for the zoom binary.
-rw-r--r--nongnu/packages/messaging.scm15
1 files changed, 13 insertions, 2 deletions
diff --git a/nongnu/packages/messaging.scm b/nongnu/packages/messaging.scm
index 4c6b2cf..a3ae9d1 100644
--- a/nongnu/packages/messaging.scm
+++ b/nongnu/packages/messaging.scm
@@ -15,10 +15,10 @@
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages kerberos)
#:use-module (gnu packages linux)
#:use-module (gnu packages nss)
#:use-module (gnu packages pulseaudio)
- #:use-module (gnu packages qt)
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
@@ -282,6 +282,8 @@ or iOS.")
(arguments
(list #:validate-runpath? #f ; TODO: fails on wrapped binary and included other files
#:patchelf-plan
+ ;; Note: it seems like some (all?) of these only do anything in
+ ;; LD_LIBRARY_PATH, or at least needed there as well.
#~(let ((libs '("alsa-lib"
"at-spi2-atk"
"at-spi2-core"
@@ -370,15 +372,21 @@ or iOS.")
"gcc"
"glib"
"mesa"
+ "mit-krb5"
"nspr"
+ "libxcb"
"libxcomposite"
"libxdamage"
+ "libxext"
"libxkbcommon"
"libxkbfile"
"libxrandr"
"libxshmfence"
"pango"
"pulseaudio"
+ "xcb-util"
+ "xcb-util-wm"
+ "xcb-util-renderutil"
"zlib")))))))
(add-after 'wrap-where-patchelf-does-not-work 'rename-binary
;; IPC (for single sign-on and handling links) fails if the
@@ -452,13 +460,16 @@ or iOS.")
libxrender
libxshmfence
mesa
+ mit-krb5
nspr
nss
pango
pulseaudio
- qtmultimedia
+ xcb-util
xcb-util-image
xcb-util-keysyms
+ xcb-util-renderutil
+ xcb-util-wm
zlib))
(home-page "https://zoom.us/")
(synopsis "Video conference client")