summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Brielmaier <jonathan.brielmaier@web.de>2023-04-11 23:10:01 +0200
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2023-04-11 23:10:01 +0200
commit8914e78e5476b3c80bccc11fb819c656e24a528e (patch)
tree51cd9b3f1dfe5ed8fe10f0eb44a073917cbb4be7
parent0df3c7d768f220af0c0a48f176011488466855ee (diff)
nongnu: firefox: Update to 112.0 [security fixes].
Fixes CVE-2023-29531, CVE-2023-29532, CVE-2023-29533, CVE-2023-29534, CVE-2023-29535, CVE-2023-29536, CVE-2023-29537, CVE-2023-29538, CVE-2023-29539, CVE-2023-29540, CVE-2023-29541, CVE-2023-29542, CVE-2023-29543, CVE-2023-29544, CVE-2023-29545, CVE-2023-29546, CVE-2023-29547, CVE-2023-29548, CVE-2023-29549, CVE-2023-29550, CVE-2023-29551 and MFSA-TMP-2023-0001. * nongnu/packages/mozilla.scm (firefox): Update to 112.0.
-rw-r--r--nongnu/packages/mozilla.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/nongnu/packages/mozilla.scm b/nongnu/packages/mozilla.scm
index db00029..035b13e 100644
--- a/nongnu/packages/mozilla.scm
+++ b/nongnu/packages/mozilla.scm
@@ -512,20 +512,20 @@ MOZ_ENABLE_WAYLAND=1 exec ~a $@\n"
;; Update this id with every firefox update to it's release date.
;; It's used for cache validation and therefor can lead to strange bugs.
-(define %firefox-build-id "20230321000000")
+(define %firefox-build-id "20230411000000")
(define-public firefox
(package
(inherit firefox-esr)
(name "firefox")
- (version "111.0.1")
+ (version "112.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://archive.mozilla.org/pub/firefox/releases/"
version "/source/firefox-" version ".source.tar.xz"))
(sha256
- (base32 "1s6wxg12b4z5n13ijcb281ydfh4qwpqzha6x3i2y1xidlsmz7944"))))
+ (base32 "1nbmh1mlh1wnh0wkbf4x2fr3pgs41cb5gapdfc63np7sgdgih6gb"))))
(arguments
(substitute-keyword-arguments (package-arguments firefox-esr)
((#:phases phases)