summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2023-03-17 15:25:55 -0400
committerJohn Kehayias <john.kehayias@protonmail.com>2023-03-17 15:44:06 -0400
commit917c329007a7d28d5687c5cbc04754fbb60c59bf (patch)
tree6d26b9b77f159a5cf6f671ae1e53b45bd23ebfbe
parent76d776a3f547081e8f98036f7d685b99e3a84762 (diff)
nongnu: zoom: Fix background blurring and virtual backgrounds.
There is a long list of libraries for LD_LIBRARY_PATH that could be refactored into a LET form, but alas could not figure out with the many quotes and gexps how right now. Or aomhost may only need a subset of these. * nongnu/packages/messaging.scm (zoom)[patchelf-plan]: Add aomhost. [phases]{wrap-where-patchelf-does-not-work}: Wrap it.
-rw-r--r--nongnu/packages/messaging.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/nongnu/packages/messaging.scm b/nongnu/packages/messaging.scm
index a3ae9d1..7e56aff 100644
--- a/nongnu/packages/messaging.scm
+++ b/nongnu/packages/messaging.scm
@@ -323,6 +323,8 @@ or iOS.")
("lib/zoom/zoom"
,libs)
("lib/zoom/zopen"
+ ,libs)
+ ("lib/zoom/aomhost"
,libs)))
#:phases
#~(modify-phases %standard-phases
@@ -360,6 +362,49 @@ or iOS.")
,(list (string-append #$(this-package-input "nss") "/lib/nss")
#$@(map (lambda (pkg)
(file-append (this-package-input pkg) "/lib"))
+ ;; TODO: Reuse this long list as it is
+ ;; needed for aomhost. Or perhaps
+ ;; aomhost has a shorter needed list,
+ ;; but untested.
+ '("alsa-lib"
+ "atk"
+ "at-spi2-atk"
+ "at-spi2-core"
+ "cairo"
+ "cups"
+ "dbus"
+ "eudev"
+ "expat"
+ "gcc"
+ "glib"
+ "mesa"
+ "mit-krb5"
+ "nspr"
+ "libxcb"
+ "libxcomposite"
+ "libxdamage"
+ "libxext"
+ "libxkbcommon"
+ "libxkbfile"
+ "libxrandr"
+ "libxshmfence"
+ "pango"
+ "pulseaudio"
+ "xcb-util"
+ "xcb-util-wm"
+ "xcb-util-renderutil"
+ "zlib")))))
+ (wrap-program (string-append #$output "/lib/zoom/aomhost")
+ `("FONTCONFIG_PATH" ":" prefix
+ (,(string-join
+ (list
+ (string-append #$(this-package-input "fontconfig-minimal") "/etc/fonts")
+ #$output)
+ ":")))
+ `("LD_LIBRARY_PATH" prefix
+ ,(list (string-append #$(this-package-input "nss") "/lib/nss")
+ #$@(map (lambda (pkg)
+ (file-append (this-package-input pkg) "/lib"))
'("alsa-lib"
"atk"
"at-spi2-atk"
@@ -402,6 +447,8 @@ or iOS.")
(lambda _
(delete-file (string-append #$output "/environment-variables"))
(mkdir-p (string-append #$output "/bin"))
+ (symlink (string-append #$output "/lib/zoom/aomhost")
+ (string-append #$output "/bin/aomhost"))
(symlink (string-append #$output "/lib/zoom/zoom")
(string-append #$output "/bin/zoom"))
(symlink (string-append #$output "/lib/zoom/zopen")