summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2022-09-16 15:00:45 -0400
committerJohn Kehayias <john.kehayias@protonmail.com>2023-04-22 21:25:25 -0400
commit95ca791b446a641a3e9f8cfc1f6cf0e33ca290ab (patch)
tree27868cf0a125d64a96bf3787b46cde366a9ddae1
parent8914e78e5476b3c80bccc11fb819c656e24a528e (diff)
nongnu: Add libdrm-next.
* nongnu/packages/mesa.scm: New module. (libdrm-next): New variable. Taken from libdrm on the core-updates branch of Guix.
-rw-r--r--nongnu/packages/mesa.scm56
1 files changed, 56 insertions, 0 deletions
diff --git a/nongnu/packages/mesa.scm b/nongnu/packages/mesa.scm
new file mode 100644
index 0000000..d012a21
--- /dev/null
+++ b/nongnu/packages/mesa.scm
@@ -0,0 +1,56 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
+;;;
+;;; This file is not part of GNU Guix.
+;;;
+;;; This program is free software: you can redistribute it and/or modify
+;;; it under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation, either version 3 of the License, or
+;;; (at your option) any later version.
+;;;
+;;; This program is distributed in the hope that it will be useful,
+;;; but WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with this program. If not, see <https://www.gnu.org/licenses/>.
+
+(define-module (nongnu packages mesa)
+ #:use-module (gnu packages bison)
+ #:use-module (gnu packages elf)
+ #:use-module (gnu packages flex)
+ #:use-module (gnu packages freedesktop)
+ #:use-module (gnu packages xml)
+ #:use-module (gnu packages gl)
+ #:use-module (gnu packages gettext)
+ #:use-module (gnu packages llvm)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages video)
+ #:use-module (gnu packages xdisorg)
+ #:use-module (gnu packages xorg)
+ #:use-module (gnu packages vulkan)
+ #:use-module (guix build-system meson)
+ #:use-module (guix download)
+ #:use-module (guix packages)
+ #:use-module (guix utils)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (ice-9 match)
+ #:use-module (srfi srfi-1))
+
+;; Taken from (gnu packages xdisorg) on the current core-updates branch.
+;; Remove once merged to Guix's master branch.
+(define libdrm-next
+ (package
+ (inherit libdrm)
+ (version "2.4.112")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://dri.freedesktop.org/libdrm/libdrm-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1zr0hi7k5s7my4q9hyj6ryzg89zyjx24zbqfv3c5rcq9pl87gc00"))))))