summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYash Tiwari <yasht@mailbox.org>2023-02-18 13:34:44 +0530
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2023-03-04 12:06:02 +0100
commitb8f0231f35f0e82c6d196b5cbdbeab3bd463bb93 (patch)
tree8b5e5679f8692d88ba088d7c38af7888ada9dc14
parent110f914f81d0d2c67a45f9b2f87a5dc7ec54dfd0 (diff)
nongnu: corrupt-linux: Allow custom configs.
This allows access to the "configs" keyword argument from the 'corrupt-linux' procedure. This simplifies creation of kernels with custom modules. * nongnu/packages/linux.scm (corrupt-linux): Add 'configs' argument. Signed-off-by: Jonathan Brielmaier <jonathan.brielmaier@web.de>
-rw-r--r--nongnu/packages/linux.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/nongnu/packages/linux.scm b/nongnu/packages/linux.scm
index f82be7d..8f9ae13 100644
--- a/nongnu/packages/linux.scm
+++ b/nongnu/packages/linux.scm
@@ -47,7 +47,7 @@
"/linux/kernel/v" (version-major version) ".x"
"/linux-" version ".tar.xz"))
-(define* (corrupt-linux freedo #:key (name "linux"))
+(define* (corrupt-linux freedo #:key (name "linux") (configs '()))
;; TODO: This very directly depends on guix internals.
;; Throw it all out when we manage kernel hashes.
@@ -78,7 +78,8 @@
#:source (origin
(method url-fetch)
(uri url)
- (hash hash))))
+ (hash hash))
+ #:configs configs))
(version version)
(home-page "https://www.kernel.org/")
(synopsis "Linux kernel with nonfree binary blobs included")